VOOZH about

URL: https://schema.ocsf.io/1.3.0/classes/authentication?extensions=linux

⇱ Open Cybersecurity Schema Framework


Authentication [3002] Class

Identity & Access Management Category

Authentication events report authentication session activities such as user attempts a logon or logoff, successfully or otherwise.
Name Caption Group Requirement Type Description
activity_id Activity ID classification Required Integer The normalized identifier of the activity that triggered the event.
0Unknown
The event activity is unknown.
1Logon
A new logon session was requested.
2Logoff
A logon session was terminated and no longer exists.
3Authentication Ticket
A Kerberos authentication ticket (TGT) was requested.
4Service Ticket Request
A Kerberos service ticket was requested.
5Service Ticket Renew
A Kerberos service ticket was renewed.
6Preauth
A preauthentication stage was engaged.
99Other
The event activity is not mapped. See the activity_name attribute, which contains a data source specific value.
This is an enum attribute; its string sibling is activity_name.
activity_name Activity classification Optional String The event activity name, as defined by the activity_id.
This is the string sibling of enum attribute activity_id.
actor Actor context Optional Actor The actor that requested the authentication.
api API Details context Optional API Describes details about a typical API (Application Programming Interface) call.
auth_factors Authentication Factors context Optional Authentication Factor Array Describes a category of methods used for identity verification in an authentication attempt.
auth_protocol Auth Protocol primary Recommended String The authentication protocol as defined by the caption of 'auth_protocol_id'. In the case of 'Other', it is defined by the event source.
This is the string sibling of enum attribute auth_protocol_id.
auth_protocol_id Auth Protocol ID primary Recommended Integer The normalized identifier of the authentication protocol used to create the user session.
0Unknown
The authentication protocol is unknown.
1NTLM
2Kerberos
3Digest
4OpenID
5SAML
6OAUTH 2.0
7PAP
8CHAP
9EAP
10RADIUS
99Other
The authentication protocol is not mapped. See the auth_protocol attribute, which contains a data source specific value.
This is an enum attribute; its string sibling is auth_protocol.
category_name Category classification Optional String The event category name, as defined by category_uid value: Identity & Access Management.
This is the string sibling of enum attribute category_uid.
category_uid Category ID classification Required Integer The category unique identifier of the event.
3Identity & Access Management
Identity & Access Management (IAM) events relate to the supervision of the system's authentication and access control model. Examples of such events are the success or failure of authentication, granting of authority, password change, entity change, privileged use etc.
This is an enum attribute; its string sibling is category_name.
certificate Certificate primary Recommended Digital Certificate The certificate associated with the authentication or pre-authentication (Kerberos).
class_name Class classification Optional String The event class name, as defined by class_uid value: Authentication.
This is the string sibling of enum attribute class_uid.
class_uid Class ID classification Required Integer The unique identifier of a class. A class describes the attributes available in an event.
3002Authentication
Authentication events report authentication session activities such as user attempts a logon or logoff, successfully or otherwise.
This is an enum attribute; its string sibling is class_name.
cloud Cloud primary Required Cloud Describes details about the Cloud environment where the event was originally created or logged.
count Count occurrence Optional Integer The number of times that events in the same logical group occurred during the event Start Time to End Time period.
device Device O primary Recommended Device An addressable device, computer system or host.
dst_endpoint Destination Endpoint O primary Recommended (†) Network Endpoint The endpoint to which the authentication was targeted.
duration Duration Milliseconds occurrence Optional Long The event duration or aggregate time, the amount of time the event covers from start_time to end_time in milliseconds.
end_time End Time occurrence Optional Timestamp The end time of a time period, or the time of the most recent event included in the aggregate event.
end_time_dt End Time occurrence Optional Datetime The end time of a time period, or the time of the most recent event included in the aggregate event.
enrichments Enrichments context Optional Enrichment Array The additional information from an external data source, which is associated with the event or a finding. For example add location information for the IP address in the DNS answers:[{"name": "answers.ip", "value": "92.24.47.250", "type": "location", "data": {"city": "Socotra", "continent": "Asia", "coordinates": [-25.4153, 17.0743], "country": "YE", "desc": "Yemen"}}]
http_request HTTP Request context Optional HTTP Request Details about the underlying HTTP request.
is_cleartext Cleartext Credentials context Optional Boolean Indicates whether the credentials were passed in clear text.

Note: True if the credentials were passed in a clear text protocol such as FTP or TELNET, or if Windows detected that a user's logon password was passed to the authentication package in clear text.

is_mfa Multi Factor Authentication primary Recommended Boolean Indicates whether Multi Factor Authentication was used during authentication.
is_new_logon New Logon context Optional Boolean Indicates logon is from a device not seen before or a first time account logon.
is_remote Remote primary Recommended Boolean The attempted authentication is over a remote connection.
logon_process Logon Process O context Optional Process The trusted process that validated the authentication credentials.
logon_type Logon Type primary Recommended String The logon type, normalized to the caption of the logon_type_id value. In the case of 'Other', it is defined by the event source.
This is the string sibling of enum attribute logon_type_id.
logon_type_id Logon Type ID primary Recommended Integer The normalized logon type identifier.
0Unknown
The logon type is unknown.
1System
Used only by the System account, for example at system startup.
2Interactive
A local logon to device console.
3Network
A user or device logged onto this device from the network.
4Batch
A batch server logon, where processes may be executing on behalf of a user without their direct intervention.
5OS Service
A logon by a service or daemon that was started by the OS.
7Unlock
A user unlocked the device.
8Network Cleartext
A user logged on to this device from the network. The user's password in the authentication package was not hashed.
9New Credentials
A caller cloned its current token and specified new credentials for outbound connections. The new logon session has the same local identity, but uses different credentials for other network connections.
10Remote Interactive
A remote logon using Terminal Services or remote desktop application.
11Cached Interactive
A user logged on to this device with network credentials that were stored locally on the device and the domain controller was not contacted to verify the credentials.
12Cached Remote Interactive
Same as Remote Interactive. This is used for internal auditing.
13Cached Unlock
Workstation logon.
99Other
The logon type is not mapped. See the logon_type attribute, which contains a data source specific value.
This is an enum attribute; its string sibling is logon_type.
message Message primary Recommended String The description of the event/finding, as defined by the source.
metadata Metadata context Required Metadata The metadata associated with the event or a finding.
observables Observables primary Recommended Observable Array The observables associated with the event or a finding.
osint OSINT primary Required OSINT Array The OSINT (Open Source Intelligence) object contains details related to an indicator such as the indicator itself, related indicators, geolocation, registrar information, subdomains, analyst commentary, and other contextual information. This information can be used to further enrich a detection or finding by providing decisioning support to other analysts and engineers.
raw_data Raw Data context Optional String The raw event/finding data as received from the source.
service Service primary Recommended (†) Service The service or gateway to which the user or process is being authenticated
session Session primary Recommended Session The authenticated user or service session.
severity Severity classification Optional String The event/finding severity, normalized to the caption of the severity_id value. In the case of 'Other', it is defined by the source.
This is the string sibling of enum attribute severity_id.
severity_id Severity ID classification Required Integer

The normalized identifier of the event/finding severity.

The normalized severity is a measurement the effort and expense required to manage and resolve an event or incident. Smaller numerical values represent lower impact events, and larger numerical values represent higher impact events.
0Unknown
The event/finding severity is unknown.
1Informational
Informational message. No action required.
2Low
The user decides if action is needed.
3Medium
Action is required but the situation is not serious at this time.
4High
Action is required immediately.
5Critical
Action is required immediately and the scope is broad.
6Fatal
An error occurred but it is too late to take remedial action.
99Other
The event/finding severity is not mapped. See the severity attribute, which contains a data source specific value.
This is an enum attribute; its string sibling is severity.
src_endpoint Source Endpoint O primary Recommended Network Endpoint Details about the source of the IAM activity.
start_time Start Time occurrence Optional Timestamp The start time of a time period, or the time of the least recent event included in the aggregate event.
start_time_dt Start Time occurrence Optional Datetime The start time of a time period, or the time of the least recent event included in the aggregate event.
status Status primary Recommended String The event status, normalized to the caption of the status_id value. In the case of 'Other', it is defined by the event source.
This is the string sibling of enum attribute status_id.
status_code Status Code primary Recommended String The event status code, as reported by the event source.

For example, in a Windows Failed Authentication event, this would be the value of 'Failure Code', e.g. 0x18.
status_detail Status Detail primary Recommended String The details about the authentication request. For example, possible details for Windows logon or logoff events are:
  • Success
    • LOGOFF_USER_INITIATED
    • LOGOFF_OTHER
  • Failure
    • USER_DOES_NOT_EXIST
    • INVALID_CREDENTIALS
    • ACCOUNT_DISABLED
    • ACCOUNT_LOCKED_OUT
    • PASSWORD_EXPIRED
status_id Status ID primary Recommended Integer The normalized identifier of the event status.
0Unknown
The status is unknown.
1Success
2Failure
99Other
The event status is not mapped. See the status attribute, which contains a data source specific value.
This is an enum attribute; its string sibling is status.
time Event Time occurrence Required Timestamp The normalized event occurrence time or the finding creation time.
time_dt Event Time occurrence Optional Datetime The normalized event occurrence time or the finding creation time.
timezone_offset Timezone Offset occurrence Recommended Integer The number of minutes that the reported event time is ahead or behind UTC, in the range -1,080 to +1,080.
type_name Type Name classification Optional String The event/finding type name, as defined by the type_uid.
This is the string sibling of enum attribute type_uid.
type_uid Type ID classification Required Long The event/finding type ID. It identifies the event's semantics and structure. The value is calculated by the logging system as: class_uid * 100 + activity_id.
300200Authentication: Unknown
300201Authentication: Logon
A new logon session was requested.
300202Authentication: Logoff
A logon session was terminated and no longer exists.
300203Authentication: Authentication Ticket
A Kerberos authentication ticket (TGT) was requested.
300204Authentication: Service Ticket Request
A Kerberos service ticket was requested.
300205Authentication: Service Ticket Renew
A Kerberos service ticket was renewed.
300206Authentication: Preauth
A preauthentication stage was engaged.
300299Authentication: Other
This is an enum attribute; its string sibling is type_name.
unmapped Unmapped Data context Optional Object The attributes that are not mapped to the event schema. The names and values of those attributes are specific to the event source.
user User O primary Required User The subject (user/role or account) to authenticate.
Constraints
† At least one of these attributes must be present: dst_endpoint, service
Attribute Associations
actor.user: src_endpoint
src_endpoint: actor.user
dst_endpoint: user
user: dst_endpoint
OCSF Server version 3.1.0. Copyright © OCSF a Series of LF Projects, LLC. For web site terms of use, trademark policy and other project policies please see LF Projects, LLC. This content includes the ICD Schema developed by Symantec, a division of Broadcom.