VOOZH about

URL: https://schema.ocsf.io/1.3.0/classes/data_security_finding

⇱ Open Cybersecurity Schema Framework


Data Security Finding [2006] Class

Findings Category

A Data Security Finding describes detections or alerts generated by various data security products such as Data Loss Prevention (DLP), Data Classification, Secrets Management, Digital Rights Management (DRM), Data Security Posture Management (DSPM), and similar tools. These detections or alerts can be created using fingerprinting, statistical analysis, machine learning or other methodologies. The finding describes the actors and endpoints who accessed or own the sensitive data, as well as the resources which store the sensitive data.
Name Caption Group Requirement Type Description
action Action primary Optional String The normalized caption of action_id.
This is the string sibling of enum attribute action_id.
action_id Action ID primary Required Integer The action taken by a control or other policy-based system leading to an outcome or disposition. Dispositions conform to an action of 1 'Allowed' or 2 'Denied' in most cases. Note that 99 'Other' is not an option. No action would equate to 1 'Allowed'. An unknown action may still correspond to a known disposition. Refer to disposition_id for the outcome of the action.
0Unknown
The action was unknown. The disposition_id attribute may still be set to a non-unknown value, for example 'Count', 'Uncorrected', 'Isolated', 'Quarantined' or 'Exonerated'.
1Allowed
The activity was allowed. The disposition_id attribute should be set to a value that conforms to this action, for example 'Allowed', 'Approved', 'Delayed', 'No Action', 'Count' etc.
2Denied
The attempted activity was denied. The disposition_id attribute should be set to a value that conforms to this action, for example 'Blocked', 'Rejected', 'Quarantined', 'Isolated', 'Dropped', 'Access Revoked, etc.
99Other
The action was not mapped. See the action attribute, which contains a data source specific value.
This is an enum attribute; its string sibling is action.
activity_id Activity ID classification Required Integer The normalized identifier of the Data Security Finding activity.
0Unknown
The event activity is unknown.
1Create
A new Data Security finding is created.
2Update
An existing Data Security finding is updated with more information.
3Close
An existing Data Security finding is closed, this can be due to any resolution (e.g., True Positive, False Positive, etc.).
4Suppressed
An existing Data Security finding is suppressed due to inaccurate detection techniques or a known true negative.
99Other
The event activity is not mapped. See the activity_name attribute, which contains a data source specific value.
This is an enum attribute; its string sibling is activity_name.
activity_name Activity classification Optional String The Data Security finding activity name, as defined by the activity_id.
This is the string sibling of enum attribute activity_id.
actor Actor context Recommended Actor Describes details about the actor implicated in the data security finding. Either an actor that owns a particular digital file or information store, or an actor which accessed classified or sensitive data.
api API Details context Optional API Describes details about a typical API (Application Programming Interface) call.
attacks MITRE ATT&CK® Details primary Optional MITRE ATT&CK® Array An array of MITRE ATT&CK® objects describing the tactics, techniques & sub-techniques identified by a security control or finding.
authorizations Authorization Information primary Optional Authorization Result Array Provides details about an authorization, such as authorization outcome, and any associated policies related to the activity/event.
category_name Category classification Optional String The event category name, as defined by category_uid value: Findings.
This is the string sibling of enum attribute category_uid.
category_uid Category ID classification Required Integer The category unique identifier of the event.
2Findings
Findings events report findings, detections, and possible resolutions of malware, anomalies, or other actions performed by security products.
This is an enum attribute; its string sibling is category_name.
class_name Class classification Optional String The event class name, as defined by class_uid value: Data Security Finding.
This is the string sibling of enum attribute class_uid.
class_uid Class ID classification Required Integer The unique identifier of a class. A class describes the attributes available in an event.
2006Data Security Finding
A Data Security Finding describes detections or alerts generated by various data security products such as Data Loss Prevention (DLP), Data Classification, Secrets Management, Digital Rights Management (DRM), Data Security Posture Management (DSPM), and similar tools. These detections or alerts can be created using fingerprinting, statistical analysis, machine learning or other methodologies. The finding describes the actors and endpoints who accessed or own the sensitive data, as well as the resources which store the sensitive data.
This is an enum attribute; its string sibling is class_name.
cloud Cloud primary Required Cloud Describes details about the Cloud environment where the event was originally created or logged.
comment Comment context Optional String A user provided comment about the finding.
confidence Confidence context Optional String The confidence, normalized to the caption of the confidence_id value. In the case of 'Other', it is defined by the event source.
confidence_id Confidence Id context Recommended Integer The normalized confidence refers to the accuracy of the rule that created the finding. A rule with a low confidence means that the finding scope is wide and may create finding reports that may not be malicious in nature.
0Unknown
The normalized confidence is unknown.
1Low
2Medium
3High
99Other
The confidence is not mapped to the defined enum values. See the confidence attribute, which contains a data source specific value.
This is an enum attribute.
confidence_score Confidence Score context Optional Integer The confidence score as reported by the event source.
count Count occurrence Optional Integer The number of times that events in the same logical group occurred during the event Start Time to End Time period.
data_security Data Security context Recommended Data Security The Data Security object describes the characteristics, techniques and content of a Data Loss Prevention (DLP), Data Loss Detection (DLD), Data Classification, or similar tools' finding, alert, or detection mechanism(s).
database Database context Recommended Database Describes the database where classified or sensitive data is stored in, or was accessed from. Databases are typically datastore services that contain an organized collection of structured and/or semi-structured data.
databucket Databucket context Recommended Databucket Describes the databucket where classified or sensitive data is stored in, or was accessed from. The data bucket object is a basic container that holds data, typically organized through the use of data partitions.
device Device O context Recommended Device Describes the device where classified or sensitive data is stored in, or was accessed from.
disposition Disposition primary Optional String The disposition name, normalized to the caption of the disposition_id value. In the case of 'Other', it is defined by the event source.
This is the string sibling of enum attribute disposition_id.
disposition_id Disposition ID primary Recommended Integer Describes the outcome or action taken by a security control, such as access control checks, malware detections or various types of policy violations.
0Unknown
The disposition is unknown.
1Allowed
Granted access or allowed the action to the protected resource.
2Blocked
Denied access or blocked the action to the protected resource.
3Quarantined
A suspicious file or other content was moved to a benign location.
4Isolated
A session was isolated on the network or within a browser.
5Deleted
A file or other content was deleted.
6Dropped
The request was detected as a threat and resulted in the connection being dropped.
7Custom Action
A custom action was executed such as running of a command script. Use the message attribute of the base class for details.
8Approved
A request or submission was approved. For example, when a form was properly filled out and submitted. This is distinct from 1 'Allowed'.
9Restored
A quarantined file or other content was restored to its original location.
10Exonerated
A suspicious or risky entity was deemed to no longer be suspicious (re-scored).
11Corrected
A corrupt file or configuration was corrected.
12Partially Corrected
A corrupt file or configuration was partially corrected.
13Uncorrected
A corrupt file or configuration was not corrected.
14Delayed
An operation was delayed, for example if a restart was required to finish the operation.
15Detected
Suspicious activity or a policy violation was detected without further action.
16No Action
The outcome of an operation had no action taken.
17Logged
The operation or action was logged without further action.
18Tagged
A file or other entity was marked with extended attributes.
19Alert
The request or activity was detected as a threat and resulted in a notification but request was not blocked.
20Count
Counted the request or activity but did not determine whether to allow it or block it.
21Reset
The request was detected as a threat and resulted in the connection being reset.
22Captcha
Required the end user to solve a CAPTCHA puzzle to prove that a human being is sending the request.
23Challenge
Ran a silent challenge that required the client session to verify that it's a browser, and not a bot.
24Access Revoked
The requestor's access has been revoked due to security policy enforcements. Note: use the Host profile if the User or Actor requestor is not present in the event class.
25Rejected
A request or submission was rejected. For example, when a form was improperly filled out and submitted. This is distinct from 2 'Blocked'.
26Unauthorized
An attempt to access a resource was denied due to an authorization check that failed. This is a more specific disposition than 2 'Blocked' and can be complemented with the authorizations attribute for more detail.
27Error
An error occurred during the processing of the activity or request. Use the message attribute of the base class for details.
99Other
The disposition is not mapped. See the disposition attribute, which contains a data source specific value.
This is an enum attribute; its string sibling is disposition.
dst_endpoint Destination Endpoint O context Recommended Network Endpoint Describes the endpoint where classified or sensitive data is stored in, or was accessed from.
duration Duration Milliseconds occurrence Optional Long The event duration or aggregate time, the amount of time the event covers from start_time to end_time in milliseconds.
end_time End Time occurrence Optional Timestamp The time of the most recent event included in the finding.
end_time_dt End Time occurrence Optional Datetime The time of the most recent event included in the finding.
enrichments Enrichments context Optional Enrichment Array The additional information from an external data source, which is associated with the event or a finding. For example add location information for the IP address in the DNS answers:[{"name": "answers.ip", "value": "92.24.47.250", "type": "location", "data": {"city": "Socotra", "continent": "Asia", "coordinates": [-25.4153, 17.0743], "country": "YE", "desc": "Yemen"}}]
file File O context Recommended File Describes a file that contains classified or sensitive data.
finding_info Finding Information primary Required Finding Information Describes the supporting information about a generated finding.
firewall_rule Firewall Rule primary Optional Firewall Rule The firewall rule that triggered the event.
impact Impact context Optional String The impact , normalized to the caption of the impact_id value. In the case of 'Other', it is defined by the event source.
This is the string sibling of enum attribute impact_id.
impact_id Impact ID context Optional Integer The normalized impact of the finding.
0Unknown
The normalized impact is unknown.
1Low
2Medium
3High
4Critical
99Other
The impact is not mapped. See the impact attribute, which contains a data source specific value.
This is an enum attribute; its string sibling is impact.
impact_score Impact context Optional Integer The impact of the finding, valid range 0-100.
malware Malware primary Optional Malware Array A list of Malware objects, describing details about the identified malware.
message Message primary Recommended String The description of the event/finding, as defined by the source.
metadata Metadata context Required Metadata The metadata associated with the event or a finding.
observables Observables primary Recommended Observable Array The observables associated with the event or a finding.
osint OSINT primary Required OSINT Array The OSINT (Open Source Intelligence) object contains details related to an indicator such as the indicator itself, related indicators, geolocation, registrar information, subdomains, analyst commentary, and other contextual information. This information can be used to further enrich a detection or finding by providing decisioning support to other analysts and engineers.
raw_data Raw Data context Optional String The raw event/finding data as received from the source.
resources Affected Resources context Recommended Resource Details Array Describes details about resources where classified or sensitive data is stored in, or was accessed from.
risk_level Risk Level context Optional String The risk level, normalized to the caption of the risk_level_id value.
This is the string sibling of enum attribute risk_level_id.
risk_level_id Risk Level ID context Optional Integer The normalized risk level id.
0Info
1Low
2Medium
3High
4Critical
99Other
The risk level is not mapped. See the risk_level attribute, which contains a data source specific value.
This is an enum attribute; its string sibling is risk_level.
risk_score Risk Score context Optional Integer The risk score as reported by the event source.
severity Severity classification Optional String The event/finding severity, normalized to the caption of the severity_id value. In the case of 'Other', it is defined by the source.
This is the string sibling of enum attribute severity_id.
severity_id Severity ID classification Required Integer

The normalized identifier of the event/finding severity.

The normalized severity is a measurement the effort and expense required to manage and resolve an event or incident. Smaller numerical values represent lower impact events, and larger numerical values represent higher impact events.
0Unknown
The event/finding severity is unknown.
1Informational
Informational message. No action required.
2Low
The user decides if action is needed.
3Medium
Action is required but the situation is not serious at this time.
4High
Action is required immediately.
5Critical
Action is required immediately and the scope is broad.
6Fatal
An error occurred but it is too late to take remedial action.
99Other
The event/finding severity is not mapped. See the severity attribute, which contains a data source specific value.
This is an enum attribute; its string sibling is severity.
src_endpoint Affected Resources O context Recommended Network Endpoint Details about the source endpoint where classified or sensitive data was accessed from.
start_time Start Time occurrence Optional Timestamp The time of the least recent event included in the finding.
start_time_dt Start Time occurrence Optional Datetime The time of the least recent event included in the finding.
status Status context Optional String The normalized status of the Finding set by the consumer normalized to the caption of the status_id value. In the case of 'Other', it is defined by the source.
This is the string sibling of enum attribute status_id.
status_code Status Code primary Recommended String The event status code, as reported by the event source.

For example, in a Windows Failed Authentication event, this would be the value of 'Failure Code', e.g. 0x18.
status_detail Status Detail primary Recommended String The status detail contains additional information about the event/finding outcome.
status_id Status ID context Recommended Integer The normalized status identifier of the Finding, set by the consumer.
0Unknown
The status is unknown.
1New
The Finding is new and yet to be reviewed.
2In Progress
The Finding is under review.
3Suppressed
The Finding was reviewed, determined to be benign or a false positive and is now suppressed.
4Resolved
The Finding was reviewed, remediated and is now considered resolved.
99Other
The event status is not mapped. See the status attribute, which contains a data source specific value.
This is an enum attribute; its string sibling is status.
table Table context Recommended Table Describes the table where classified or sensitive data is stored in, or was accessed from. The table object represents a table within a structured relational database, warehouse, lake, or similar.
time Event Time occurrence Required Timestamp The normalized event occurrence time or the finding creation time.
time_dt Event Time occurrence Optional Datetime The normalized event occurrence time or the finding creation time.
timezone_offset Timezone Offset occurrence Recommended Integer The number of minutes that the reported event time is ahead or behind UTC, in the range -1,080 to +1,080.
type_name Type Name classification Optional String The event/finding type name, as defined by the type_uid.
This is the string sibling of enum attribute type_uid.
type_uid Type ID classification Required Long The event/finding type ID. It identifies the event's semantics and structure. The value is calculated by the logging system as: class_uid * 100 + activity_id.
200600Data Security Finding: Unknown
200601Data Security Finding: Create
A new Data Security finding is created.
200602Data Security Finding: Update
An existing Data Security finding is updated with more information.
200603Data Security Finding: Close
An existing Data Security finding is closed, this can be due to any resolution (e.g., True Positive, False Positive, etc.).
200604Data Security Finding: Suppressed
An existing Data Security finding is suppressed due to inaccurate detection techniques or a known true negative.
200699Data Security Finding: Other
This is an enum attribute; its string sibling is type_name.
unmapped Unmapped Data context Optional Object The attributes that are not mapped to the event schema. The names and values of those attributes are specific to the event source.
OCSF Server version 3.1.0. Copyright © OCSF a Series of LF Projects, LLC. For web site terms of use, trademark policy and other project policies please see LF Projects, LLC. This content includes the ICD Schema developed by Symantec, a division of Broadcom.